No se encontró winsrv, error c0000135

Parece que Grisoft se mandó un feo moco con una actualización de AVG.

AVG

Desde aproximadamente el sábado 9/11 un tendal de máquinas al iniciar muestran una hermosa pantalla azul (a esta altura ya las amo, no podría vivir sin ellas) con el error:

STOP: c0000135 {No se puede encontrar el componente}
Error al iniciar esta aplicación porque no se encontró winsrv

Obviamente el error solo se visualiza si se tiene desactivado el reinicio automático, de otro modo el síntoma es que la PC se reinicia continuamente mientras carga Windows.

Por suerte y luego de buscar un rato, encontré la solución en el blog de Tomás:

1. Conseguir un disco live de una distribución de Linux (las últimas versiones de Ubuntu o Kubuntu son perfectas) e iniciarlo en nuestro ordenador.

2. Acceder al disco de windows y copiar una versión del fichero user32.dll en la carpeta system32. Para obtener el fichero lo podéis sacar de una instalación de Windows XP + SP2 que funcione o pedírselo a un amigo.

3. Reiniciar en modo a prueba de fallos. Para ello debemos pulsar F8 al arrancar y seleccionar la opción del menú que nos aparece

4. Eliminar el programa AVG. Aunque suene un poco radical, ya que parece que la última actualización resuelve el problema, lo mejor es eliminarlo y si queréis seguir usándolo, volvéroslo a bajar con las últimas actualizaciones incluidas.

5. Reiniciar. El sistema debería iniciarse correctamente.

Si hacéis estos pasos todo debería volver a la normalidad. Si, como yo, no queréis seguir usando AVG, me parece lamentable que un antivirus provoque estos problemas, podéis leer una comparativa entre antivirus gratuitos en genbeta para escoger el vuestro.

Desconozco cómo el amigo de Tomás supo que era el AVG el que generó el problema, pero no es casualidad que al solucionar el problema y volver a iniciar las PC TODAS éstas tenían AVG Free instalado, por cierto, si no se está muy cómodo con ubuntu se puede utilizar BartPE o cualquier CD de inicio de Windows Preinstalado,

16 Comentarios

  1. Ahhh per me viene mas que anillo al dedo, el domingo un amigo tenia este problema… como no tenia ni put* idea de que podia ser le dije que em aguante porque iba a necesitar un disco de linux para poder devolverle la PC, y ahora encuentro esto…

    Groso!

    Saludos!

  2. Nooo! no te la puedo creer, ayer mismo formateé la PC de mi viejo por este mismo problema. Ya me parecia raro que de un dia para el otro no prendiera mas.

    Pero bueno, aunque sea aproveche para limpiarla tanto fisicamente (terrible mugre tenia) como virtualmente (un cleanup del registro nunca viene mal).

  3. Muy bueno el nodo de solucionarlo, este problema se ha comentado en varios blogs de seguridad informatica, me imagino que tu amigo tambien los lee

  4. ¿Esto es de ahora? Porque que yo recuerde AVG ya se cargó varios XP (mayormente piratas) el 13/11 del año pasado. Podés ver aca la crónica.
    Igual te cuneto que desde entonces yo instalé antivir por defecto y le escapo al AVG. Otra vez no me engancha.

  5. Curioso. Ayer a un amigo le pasó justamente esto.
    Lo que dice 486 es cierto, mientras buscaba sobre el problema encontré la solución en threads de distintos foros que eran de finales del año pasado.
    Aparentemente el problema es que detecta la user32.dll como el troyano PSW.Banker4.APSA.

  6. Guille, ¿no es F8 que hay que apretar en vez de F5?

    Hace rato que no lo tengo que hacer en ninguna máquina, pero creo que era así.

  7. yo e ibaa decir lo mismo con lo del F8… pero capas el F5 andaba igual… el F5 era en Windows 3.1 si no me equivoco…

    seguramente si…

    saludos!

  8. no puedo creer que un méndigo archivo haga arrancar al XP; espero que el 7 no tenga los mismos problemas……….

  9. hola a todos necesito que me ayuden con este problema q tengo al tratar de desintalar un programa llamado Vista Inspirat version 1.1 lo desistale y al fina me pidio que lo reinicie lo reinicie y al arrancar me salio una pantalla en azul que decia STOP: c0000135 {No se puede encontrar el componente}
    Error al iniciar esta aplicación porque no se encontró winsrv

    q debo hacer porfa necesito su ayuda no quiero perder todos los datos, programas, archivos de mi compu.
    como puedo reparar esto

  10. Hice todo esto y me fue de maravilla, me sirvio de mucho lo que mencionaron.
    !!MUCHAS GRACIAS!!

  11. Tengo el mismo problema en una pc, solo que cuando rebise el disco no estaba instalado el AVG.¿alguien sabe otra posible razon del problema?. desde ya muchisimas gracias

  12. Hola, Muchas gracias por la ayuda, ha sido perfecta!

    Solo que como la PC no tiene bandeja para CD, hice un USB LIVE que trajera el UBUNTU para poder trabajar la maquina desde linux.

    Aún necesito más ayuda por favor!

    No se si pude copiar bien el user32.dll al USB para pegarlo a windows y tampoco sé como pegarlo correctamente.

    Lo que hice fué cambiar de nombre el user32.dll que ya traia la maquina y copiar el archivo que yo traia a traves del USB.

    Luego reinicié y no me funcionó, windows sigue trbado.

    Gracias

Dejar respuesta

Please enter your comment!
Please enter your name here